Rate Limitations
Resolved·Full outage

We've continued to monitor the issue following our deployed fix. We've deemed the fix as a success, and we're closing this incident. Alongside our newly introduced failsafes, we'll be more cautious moving forward. Thanks for your cooperations.

Mon, Feb 9, 2026, 10:27 PM
(2 weeks ago)
·
Affected components
Updates

Resolved

We've continued to monitor the issue following our deployed fix. We've deemed the fix as a success, and we're closing this incident. Alongside our newly introduced failsafes, we'll be more cautious moving forward. Thanks for your cooperations.

Mon, Feb 9, 2026, 10:27 PM

Monitoring

We've performed a global resync, which was approved by Discord! Kyro's services should now be operating as expected, and our engineers have restructured our code to ensure this doesn't happen again. We'll keep monitoring the situation for the next 24 hours to ensure that our services are performing as expected; as of now, they are. During this time, commands are anonymously being recorded and sent to our engineers for review; data collected includes the command used and the response time.

We've also added a new command - /ai. This command is currently broken, and we're aware of this. We've already deployed a fix and will be synced globally tomorrow. We're not performing any more syncs today to prevent further rate limitations.

Thank you for your patience. We'll let you know if any errors occur.

Mon, Feb 9, 2026, 04:13 PM(6 hours earlier)

Identified

Our engineers have restructured how our systems handle syncing commands and starting-up. As we were performing large-scale testing, which included many reboots, we reached the Discord limitation for application command syncing. We'll attempt to globally sync all commands tomorrow, when our limitation has been lifted. Thank you for your patience and understanding.

Mon, Feb 9, 2026, 12:24 AM(15 hours earlier)

Identified

We've identified the issue; following the preparation for an upcoming update, many commands that we just added were syncing at once, which caused Discord to automatically impose rate limitations on us. We're currently waiting for these rate limitations to expire, and when they do, our services will automatically return online. However, we're experiencing a full outage while we wait for this to happen, as all services bypass Discord. Our engineers will continue monitoring the situation.

Sun, Feb 8, 2026, 09:17 PM(3 hours earlier)

Investigating

Our servers are experiencing high levels of traffic, which have led to our backup servers deploying many API requests to Discord. This has overloaded our servers and caused Discord to impose a block on our API requests. Our team are actively investigating the issue. At this time, our services remain online, but responses may be slow and degraded.

Sun, Feb 8, 2026, 08:22 PM(55 minutes earlier)
Powered by

Kyro HR • kyrohr.cc